Welcome, Guest
Username: Password: Remember me

TOPIC: Shimano Ultegra 6770 di2 Issues

Shimano Ultegra 6770 di2 Issues 19 Jun 2017 16:24 #10662

  • Neil Barker
  • Neil Barker's Avatar
  • OFFLINE
  • New Member
  • Posts: 19
  • Thank you received: 1
Thanks Graeme / Lorna. I will have a look at what you suggest. Was working perfectly then all of a sudden there appears to be an issue. Searched on-line and lots of potentials to check out.
The administrator has disabled public write access.

Shimano Ultegra 6770 di2 Issues 19 Jun 2017 13:50 #10658

Not a Di2 expert but have you updated to the latest firmware? is the chainline and limit screws adjusted correctly? It could be continuing to try to shift / align the mechs even when not being ridden.

I assume that Mark L will be along shortly to tell you that you shouldn't have electric shifting and that you need a new chain (as that fixes most things apparently).
The administrator has disabled public write access.

Shimano Ultegra 6770 di2 Issues 19 Jun 2017 13:08 #10656

This shouldn't happen as it's a lithium ion battery which shouldn't self discharge more than ~2-3% a month. Which suggests there's a drain on it somewhere.
Have you checked the connection? With the battery below the BB it's exposed to loads of crap and dirt and silt can get into the unit. I've noticed this before with mine.
The administrator has disabled public write access.

Shimano Ultegra 6770 di2 Issues 19 Jun 2017 12:02 #10655

  • Neil Barker
  • Neil Barker's Avatar
  • OFFLINE
  • New Member
  • Posts: 19
  • Thank you received: 1
Hi,
Any advice welcome.
I have shimano Ultegra 6770 di2 issues. After a full charge the battery discharges (when connected to bike) within 72-96 hours despite not being used. I have bought, charged and fitted a new battery and this does exactly the same.
As I am no bike expert I wondered if anyone knew what might be causing this.
Thanks for your help.
Neil
The administrator has disabled public write access.
Designed by the Club